OP : ADD

Symbol

Description

The output is equal to the real time addition of the 2 inputs.

This model is usually used as a comparator in feedback loops to add external perturbations to the system.


OP : SUBTRACT

Symbol

Description

The output is equal to the real time subtraction of the 2 inputs.

This model is usually used as a comparator in feedback loops.


OP : MULTIPLY

Symbol

Description

The output is equal to the real time multiplication of the 2 inputs.

This model is used as a modulator when the inputs are variables or as a multiplication operator when the inputs are continuous.


OP : DIVIDE

Symbol

Description

The output is equal to the real time division of the 2 inputs.

This model is rather used as a division operator with continuous inputs.


OP : GAIN

Symbol

Description

The output is equal to the multiplication of the input by a constant K.

This model is used as an amplifier.

Parameter

K : Amplification coefficient without unit. K is a positive or negative real number. We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


OP : DIFFERENTIATE

Symbol

Description

The output is the derivative function of the input. The derivative is computed in real time.


OP : INTEGRATE

Symbol

Description

The output is the integral function of the input. The integral is computed in real time.


OP : DELAY

Symbol

Description

The input is delayed by a time T then sent to the output. This function allows to take into account the reaction time of a process.

Parameters

T : Delay value in seconds. T is a positive or negative real number We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Remark : this primitive uses the transient mode of the simulator. If you see that the rising time is too slow (output respect to the input), it may be useful to adjust the NUMSTEPS parameter to a bigger value (default value NUMSTEPS=10).

In order to do this, edit the graph and enter the following value into the field to the right :

NUMSTEPS=500


1˚ORD : 1+TP

Symbol

Description

This model is a transfer function primitive.

H(p)=1+TP

We usually use this primitive to model complex transfer functions.

Parameters

T : time constant, in seconds. T can be a positive real number.


1°ORD : 1-TP

Symbol

Description

This model is a transfer function primitive.

We usually use this primitive to model complex transfer functions.

Parameters

T : time constant, in seconds. T can be a positive real number.


1°ORD : HP

Symbol

Description

It is a first order high pass filter transfer function.

The slope is +20dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

T : time constant, in seconds. T can be a positive real number.


1°ORD : HP_F

Symbol

Description

It is a first order high pass filter transfer function.

The slope is +20dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

fc : -3dB cut-off frequency of the filter, in Hertz. Fc is a positive real number.


1°ORD : LP

Symbol

Description

It is a first order low pass filter transfer function.

The slope is -20dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

T : time constant, in seconds. T can be a positive real number.


1°ORD : LP_F

Symbol

Description

It is a first order low pass filter transfer function.

The slope is -20dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

fc : -3dB cut-off frequency of the filter, in Hertz. Fc is a positive real number.


1°ORD : POLY 1

Symbol

Description

It is a first order polynomial transfer function.

Parameters

K : Satic gain of the filter, without unit. It is a positive or negative real number.

Tn : Time constant of numerator, in seconds. T is a positive real number.

Td : Time constant of the denominator, in seconds. T is a positive real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


1°ORD : POLY 2

Symbol

Description

It is a first order polynomial transfer function.

Parameters

K : Static gain of the filter, without unit. It is a positive or negative real number.

N : value of the numerator (zero), without unit. T is a positive real number.

D : value of the denominator (pole), without unit. T is a positive real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


1°ORD : POLY 3

Symbol

Description

It is a first order polynomial transfer function.

This primitive allows to synthesize all the first order transfer functions, simply by affecting the right coefficients to N1, N0, D1 et D0.

Parameters

K : Static gain of the filter, without unit. It is a positive or negative real number.

N1 : value of the numerator ( p1) , without unit. T is a positive or negative real number.

N0 : value of the numerator (p0), without unit. T is a positive or negative real number.

D1 : value of the denominator (p1), without unit. T is a positive or negative real number.

D0 : value of the denominator (p0), without unit. T is a positive or negative real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Example : We want to model the following function:

The parameters are K = 1, N1 = 5, N0 = 1, D1 = 1, D0 =0.1


2°ORD : BP

Symbol

Description

It is a band pass transfer function.

The slope is + or - 20dB / decade on both side of the bandwidth.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

wn : normal pulsation of the filter, in Radians.s-1. Wn is a positive real number.

z : damping value of the filter, without unit. z is a positive real number.

- If z > 0,707 there is no overshoot at output,

- If z = 0,707, it is a "Butterworth" filter,

- If z < 0,707 there is an overshoot at output for w # wn.


2°ORD : HP

Symbol

Description

It is a second order high pass transfer function.

The slope is +40dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

wn : normal pulsation of the filter, in Radians.s-1. Wn is a positive real number.

z : damping value of the filter, without unit. z is a positive real number.

- If z > 0,707 there is no overshoot at output,

- If z = 0,707, it is a "Butterworth" filter,

- If z < 0,707 there is an overshoot at output for w # wn.


2°ORD : LP

Symbol

Description

It is a second order low pass transfer function.

The slope is -40dB / decade in the attenuated zone.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

wn : normal pulsation of the filter, in Radians.s-1. Wn is a positive real number.

z : damping value of the filter, without unit. z is a positive real number.

- If z > 0,707 there is no overshoot at output,

- If z = 0,707, it is a "Butterworth" filter,

- If z < 0,707 there is an overshoot at output for w # wn.


2°ORD : NOTCH

Symbol

Description

It is a band stop filter transfer function.

For the wn frequency, the attenuation is infinite.

Parameters

A : Static gain of the filter, without unit. It is a positive or negative real number.

wn : frequency rejected by the filter, in Radians.s-1. Wn is a positive real number.

Dwn : width if the rejected band (at -3dB), in Radians.s-1. Dwn is a positive real number.


2°ORD : POLY

Symbol

Description

It is a second order polynomial transfer function.

This primitive allows to synthesize all the second order transfer functions, simply by affecting the right coefficients to N2, N1, N0, D2, D1 et D0.

Parameters

K : Static gain of the filter, without unit. It is a positive or negative real number

N2 : value of the numerator ( p2) , without unit. T is a positive or negative real number

N1 : : value of the numerator ( p1) , without unit. T is a positive or negative real number

N0 : : value of the numerator (p0), without unit. T is a positive or negative real number

D2 : : value of the denominator (p2), without unit. T is a positive or negative real number

D1 : value of the denominator (p1), without unit. T is a positive or negative real number

D0 : value of the denominator (p0), without unit. T is a positive or negative real number

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Example : We want to model the following function:

The parameters are K = 1, N2 = 0, N1 = 1, N0 = 1, D2 = 3, D1 = 4, D0 =10.


PZ : P REAL

Symbol

Description

This primitive allows to get a real pole in order to model a complicated process.

Indeed, any function can be put in a "factorized" form with poles (numerator) and poles (denominator). An unspecified process can thus be described simply by the position of its poles and its zeros.

Restriction : this model only get real poles, whereas the decomposition of a function can reveal complex numbers...

Parameters

P : value of the pole, in radian.s-1. It is a positive or negative real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Example : if you want to model the function below, it will be necessary to put two blocks PZ : P REEL in series, one with P = 4 and the other with P = -2


PZ : Z REAL

Symbol

Description

This primitive allows to get a real zero in order to model a complicated process.

Indeed, any function can be put in a "factorized" form with poles (numerator) and poles (denominator). An unspecified process can thus be described simply by the position of its poles and its zeros.

Restriction : this model only get real zeros, whereas the decomposition of a function can reveal complex numbers...

Parameters

Z : value of the zero, in radian.s-1. . It is a positive or negative real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Example : if you want to model the function H(p) = (p + 3)(p - 4), it will be necessary to put two blocks PZ : Z REEL, one with Z = 4 and the other with Z = -3


PZ : P+Z REAL

Symbol

Description

This primitive allows to get a real zero and an real pole in order to model a complicated process.

Indeed, any function can be put in a "factorized" form with poles (numerator) and poles (denominator). An unspecified process can thus be described simply by the position of its poles and its zeros.

Restriction : this model only get real numbers, whereas the decomposition of a function can reveal complex numbers...

Parameters

Z : value of the zero, in radian.s-1. It is a positive or negative real number

P : value of the pole, in radian.s-1. It is a positive or negative real number

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)

Example : if you want to model the function below, it will be necessary to put 1 block PZ : P+Z REEL, with Z = -3 and P = 4


PROC : PURE DLY

Symbol

Description

This block allows to model a process composed of amplification and delay. The trace below shows the time response to a sinusoidal input. Of course, the input can be unspecified...

Parameters

Gs : Static gain of the process, without unit. It is positive or negative real number.

T : Value of the delay, in seconds. T is a positive real number.

Remark : this primitive uses the transient mode of the simulator. If you see that the rising time is too slow (output respect to the input), it may be useful to adjust the NUMSTEPS parameter to a bigger value (default value NUMSTEPS=10).

In order to do this, edit the graph and enter the following value into the field to the right :

NUMSTEPS=500

Example : for the model corresponding to the above, the parameters would be Gs = 1.5 and T = 0.3.


PROC : BROIDA

Symbol

Description

This block allows to model a process composed of amplification, pure delay an order 1 factor. One can thanks to this method model almost all the stable processes of the 1st order. We get then a process defined as:

Parameters

This process model requires the knowledge of the following parameters :

Gs : Static gain of the process, without unit. It is a positive or negative real process.

T : value of the pure delay, in seconds. T is a positive real number.

Tm : value of the order 1 factor, in seconds. Tm is a positive real number.

Remark : this primitive uses the transient mode of the simulator. If you see that the rising time is too slow (output respect to the input), it may be useful to adjust the NUMSTEPS parameter to a bigger value (default value NUMSTEPS=10).

In order to do this, edit the graph and enter the following value into the field to the right :

NUMSTEPS=500

Broïda's method : this method is divided in 4 stages. It allows to determine the parameters to enter into the PROC : BROIDA model, from a real process :

  1. linearize the answer of the process, in order to suppress the beginning of the process.
  2. determine graphically the values Smax, 0,4.Smax and 0,28.Smax of the linearized trace.
  3. get graphically the time t1 and t2, corresponding respectively to the values 0,28 and 0,4.Smax.
  4. Les paramètres du modèle sont alors :

- Gs = Smax

- T = 2,8.t1 - 1,8.t2

- Tm = 5,5 . (t2 - t1)

Example : for the model corresponding to the model below, we get t1 = 14,67s and t2 = 16,47s, the parameters would be:

- Gs = Smax = 15,00

- T = 2,8.t1 - 1,8.t2 = 11,43

- Tm = 5,5 . (t2 - t1) = 9,9


PROC : ZIEGLER

Symbol

Description

This block allows to model un process composed of amplification, a pure delay and an integrator. This model is usually used as first order process with delay, with strong slope. It is a complement of the Broïda's model.

Parameters

Gs : Static gain of the process, without unit. It is a positive or negative real number.

T : value of the delay, in seconds. T is a positive real number.

Remark : this primitive uses the transient mode of the simulator. If you see that the rising time is too slow (output respect to the input), it may be useful to adjust the NUMSTEPS parameter to a bigger value (default value NUMSTEPS=10).

In order to do this, edit the graph and enter the following value into the field to the right :

NUMSTEPS=500

Ziegler's method : this method is divided in several stages. It allows to define the parameters to enter into the model PROC : ZIEGLER model, from a real process:

  1. linearize the response of the real process, in order to suppress the end of the response.
  2. determine the value of the delay T, by prolongation,
  3. computes the slope of the straight line, which corresponds at Gs.

Example : for the model corresponding to the figure below, the parameters would be

- T = 2,7


CTRL : P

Symbol

Description

Proportional controller model. The gain of the process is constant over all the frequency range. The proportional controller decreases the steady state error and the rise time and increases the overshoot.

Parameters

Gp : gain, without unit. It is a positive or negative real number

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


CTRL : PD

Symbol

Description

Proportional derivative control. It decreases the overshoot and the settling time. The response of this controller is :

Parameters

Gd : gain, without unit. It is a positive or negative real number.

Td : derivative time constant, in seconds. It is a positive real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


CTRL : PI

Symbol

Description

Proportional integral control. It decreases the rise time, eliminates the steady state error and increases both the overshoot and the settling time. The response of this controller is :

Parameters

Gi : gain, without unit. It is a positive or negative real number.

Ti : integral time constant, in seconds. It is a positive real number.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


CTRL : PID

Symbol

Description

It is the PID model. With this model, you can personalize the type of corrector desired, in order to improve rise-time, the overshoot and the steady-state error. The frequency response is given below :

The adjustement of this corrector is often delicate. In general:

- on compense le pôle lent du processus à réguler par Tm,

- on calcule Ti de façon à satisfaire aux critères d'erreur,

- on détermine Tv pour assurer la marge de phase demandée.

- G reste le plus souvent à 1.0 mais peut être utilisé pour affiner.

Remark : on peut également déterminer les valeurs de Tm,Tc et Ti par identification de la fonction de transfert avec celle obtenue grâce à la méthode de réglage de Ziegler et Nichols.

Parameters

G : Gain value, without unit. It is a positive or negative real number.

Tm : Compensation time constant of the slow pole, in seconds. It is a positive real.

Tv : Compensation time constant of the fast pole, in seconds. It is a positive real.

Ti : Integration time constant, in seconds. It is a positive real.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


CTRL : ADVANCE

Symbol

Description

It is the phase advance controller. Simpler to get than a PD controller, we use this controller in a feedback loop in order to eliminate the static error, and set the rapidity of the system. The frequency response is shown below :

Placement :

- we try to centre the embarrassing time constant of the process to regulate between Td and a.Td.

- Kc should stay to 1.0 but can be modified to refine.

Parameters

Kc : Gain value of the controller, without unit. It is a real number, positive or negative.

Td : Derivative time co[nstant, in seconds. It is a positive real.

a : Phase advance factor, without unit. It is a positive real.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


CTRL : DELAY

Symbol

Description

It is the phase delay controller. Simpler to get than a PI controller, we use this controller in a feedback loop in order to eliminate the static error, and set the rapidity of the system. The frequency response is shown below :

Placement :

- we try to centre the embarrassing time constant of the process to regulate between Ti and d.Ti.

- Kc should stay to 1.0 but can be modified to refine.

Parameter

Kc : Gain value of the controller, without unit. It is a real number, positive or negative.

Ti : Integration time constant, in seconds. It is un positive real.

d : Phase delay factor, without unit. It is a positive real.

Remark : We recommend to use the exponential notation (e.g. : 5.02E+3) instead of the symbolic notation (e.g. : 5.02k)


NL : SWITCH

Symbol

Description

It is the simpler non linear corrector. The response is binary:

If input < threshold S, then output = -sat,

If input > threshold S, then output = +sat,

Parameters

S : threshold value. It is a positive or negative real number.

+sat : positive output value, in volts. It is a positive or negative real number.

- sat : negative output value, in volts. It is a positive or negative real number.


NL : SW DZ

Symbol

Description

It is a corrector with a "dead zone", divided in 3 stages:

If input < threshold vt-, the output = -sat,

If input vt- < input < input vt+, then output = 0 : it is the "dead zone",

If input > threshold vt+, then output = +sat.

Parameters

vt- : value of the first threshold. It is a positive or negative real number.

vt+ : value of the second threshold. It is a positive or negative real number.

+sat : value of the positive output in volts. It is a positive or negative real number.

- sat : value of the negative output in volts. It is a positive or negative real number.


NL : SW HYST

Symbol

Description

It is a corrector with hysteresis:

-if the input increases, then the output will switch from -sat to +sat when input > threshold vt+.

-if the input decreases, then the output will switch from +sat to -sat when input < threshold vt-.

Parameters

vt- : value of the first threshold. It is a positive or negative real number

vt+ : value of the second threshold. It is a positive or negative real number

+sat : value of the positive output in volts. It is a positive or negative real number

- sat : value of the negative output in volts. It is a positive or negative real number


NL : AMP SAT

Symbol

Description

It is an amplifier corrector with saturation:

-if input < threshold vt-, then output = -sat,

-if threshold vt- < input < threshold vt+, then output = Gain x input : it is the amplification zone,

-if input > threshold vt+, then output = +sat.

Parameters

Gain : gain of the linear zone, without unit. It is a positive or negative real number

+sat : value of the positive output in volts. It is a positive or negative real number

- sat : value of the negative output in volts. It is a positive or negative real number

Example : a perfect operational amplifier can be modelled, with the following values, for example Gain = 10.106, +sat = 15 and -sat = -15 .


NL : AMP DZ

Symbol

Description

It is an amplifier corrector, with dead zone :

if input < threshold vt-, then output = Gain x input,

if threshold vt- < input < threshold vt+, then output = 0 : it is the 'dead zone',

if input > threshold vt+, then output = Gain x input.

The traditional use of such a corrector is the amplifier class B PUSH PULL, where the dead zone correspond to the Vbe voltage of transistors.

Parameters

Gain : value of the gain in the linear zone, without unit. It is a positive or negative real number

vt- : value of the first threshold. It is a positive or negative real number

vt+ : value of the second threshold. It is a positive or negative real number

Example : a PUSH PULL with bipolar transistors amplifier can be modelled, with for example Gain = 1, vt+ = 0,65 and vt- = -0,65 .


NL : AMP PL

Symbol

Description

This corrector is very particular, it has got a threshold and a bias characteristic:

If input < threshold S, then output = Gain x (entrée - S) -off,

If input < threshold S-, then output = -off,

If input < threshold S, then output = 0,

If input < threshold S+, then output = +off,

If input < threshold S+, then output = Gain x (entrée - S) +off.

Remark : The values S- and S+ are values close to S (just before or after S).

Parameters

Gain : gain value in the linear zone, without unit. . It is a positive or negative real number

S : value of the switch threshold. It is a positive or negative real number

-off : value of the negative bias in volts. . It is a positive or negative real number

+off : value of the positive bias in volts. . It is a positive or negative real number